Bug Can't edit or delete pics in albums?


Well-Known Member
I uploaded a pic and want to change the caption. I'm not seeing an option to either edit or delete what's been posted in my album. I can only move it to another album. So if we add content to the albums we don't have the ability to change or remove it at all?
I have been having this issue since 10/10 also. I can add pictures but not delete them. I was trying to update my staples album when I noticed this.
@Rocky91 and @Lylddlebit thanks for letting us know of this problem and for your patience. There may be a delay with resolving this issue but know we are working to fix this as soon as possible. This is a newer software and the updates have to slow to roll out for the enhanced features

This is a bit of a head scratcher. The permission to delete albums and media is there. I am not sure if it interferes with something else and does not allow you to delete/edit pictures etc.

I did make a couple of tweaks. Could you please let me know if this solved this issue?

It's still not working for me in Chrome. I also checked Firefox and have the same experience in both.

If I look at a pic in my album I have the option to Set as avatar or Move media item. If I open the pic in a new window, I get an additional option to check a box to Select for moderation.
I just tested this one, it should be resolved.

Thank you all for the patience and help in letting me identify where the problem was.
thanks to dimopoulos and to you all for the feedback & making us aware of this issue. I know we can be a little slow at times, but we appreciate your patience with us.